appleberry

joined 2 years ago
 

I'm new to elixir and just tried to install the elixirLS extension for VScode(ium) and it is throwing some errors that I would like help in understanding. I have not gotten to the stage of writing any code, only browsing to my tutorial folder.

I can see it's missing asdf, vfox & mise. Asdf seems to be some tool version manager (just what I wanted!) Ok, so is vfox... and mise.

Then it is also asking for SSL. I have tried installing openssl on my system, but it didn't fix the issue and I don't feel great about installing a million packages on my sytem hoping for the issue to go away when this was not mentioned in the elixir install instruction (or the tutorial).

I'm not sure what VScode is trying to do right now when I install the extension. Im guessing that maybe it's trying to start a erlang vm to be able to run code when Im ready, or maybe it needs one it to do the linting or something.

I just disabled/enabled the extension on an empty folder and there are no errors. So maybe I can ignore this until later.

If you have any advice to improve my understanding, that would be wonderful. Thanks.

2026-08-31 11:02:57.232 [error] Running /home/apz/.vscode-oss/extensions/elixir-lsp.elixir-ls-0.31.1-universal/elixir-ls-release/launch.sh
2026-08-31 11:02:57.234 [error] Preferred shell is fish, launching launch.fish
2026-08-31 11:02:57.263 [error] Looking for asdf install
2026-08-31 11:02:57.264 [error] which: no asdf in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)
2026-08-31 11:02:57.264 [error] asdf not found
2026-08-31 11:02:57.264 [error] Looking for mise executable
2026-08-31 11:02:57.264 [error] which: no mise in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)
2026-08-31 11:02:57.264 [error] mise not found
2026-08-31 11:02:57.264 [error] Looking for vfox executable
2026-08-31 11:02:57.265 [error] which: no vfox in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)
2026-08-31 11:02:57.265 [error] vfox not found
2026-08-31 11:02:57.882 [error] Installing ElixirLS release v0.31.1
2026-08-31 11:02:57.882 [error] Running in /home/apz/Projects/pragstudio-elixir-code
2026-08-31 11:02:57.935 [error] * Updating elixir_ls (https://github.com/elixir-lsp/elixir-ls.git - v0.31.1)
2026-08-31 11:02:58.607 [error] ** (EXIT from #PID<0.95.0>) an exception was raised:
2026-08-31 11:02:58.607 [error]     ** (Mix.Error) The application "ssl" could not be found. This may happen if your Operating System broke Erlang into multiple packages and may be fixed by installing the missing "erlang-dev" and "erlang-ssl" packages
2026-08-31 11:02:58.607 [error]         (mix 1.20.2) lib/mix.ex:647: Mix.raise/2
2026-08-31 11:02:58.608 [error]         (mix 1.20.2) lib/mix.ex:706: Mix.ensure_application!/4
2026-08-31 11:02:58.608 [error]         (mix 1.20.2) lib/mix.ex:678: Mix.ensure_application!/1
2026-08-31 11:02:58.608 [error]         (mix 1.20.2) lib/mix/utils.ex:864: Mix.Utils.read_httpc/1
2026-08-31 11:02:58.608 [error]         (mix 1.20.2) lib/mix/utils.ex:808: anonymous fn/2 in Mix.Utils.read_path/2
2026-08-31 11:02:58.608 [error]         (elixir 1.20.2) lib/task/supervised.ex:105: Task.Supervised.invoke_mfa/2
2026-08-31 11:02:58.608 [error]         (elixir 1.20.2) lib/task/supervised.ex:40: Task.Supervised.reply/4
2026-08-31 11:02:58.608 [error] 
2026-08-31 11:02:58.616 [error] Server process exited with code 1.
2026-08-31 11:02:58.617 [error] Server initialization failed.
elixir --version
Erlang/OTP 29 [erts-17.0.1] [source] [64-bit] [smp:12:12] [ds:12:12:10] [async-threads:1] [jit:ns]

Elixir 1.20.2 (compiled with Erlang/OTP 29)

7.1.4-1-cachyos

[โ€“] appleberry@aussie.zone 1 points 1 year ago

Thanks. I did create a persistent volume, but I thought that deleting the files would trigger them to be recreated when the container restarts.

 

I have set up my site.conf as a site.conf.template file in /etc/nginx/templates/

It has successfully been copied into etc/nginx/conf.d before, but after making some changes to the template and rebuilding the container, it is not copying again. There are no errors in the docker log for the nginx container, in fact it is running (without the sites config).

I have tried changing the local copy of conf.d to 775, but other than that I can't think of what would be stopping it from copying or triggering. Or where to look for error logs. ๐Ÿ™

[โ€“] appleberry@aussie.zone 3 points 1 year ago

SOLUTION: The log file is definitely changing the case of the variables as they appear in .conf ๐Ÿ˜….

3
submitted 1 year ago* (last edited 1 year ago) by appleberry@aussie.zone to c/docker@programming.dev
 

I'm new to docker.

I'm trying to run the nginx/alpine container and getting this error:

2025/08/10 01:09:55 [emerg] 1#1: unknown "flask_port" variable nginx: [emerg] unknown "flask_port" variable

Strangely, there is no flask_port reference in my codebase (having grepped for it in ./*). There is FLASK_PORT, but it seems unlikely that that the case for the missing variable would get changed before outputting to the log file, right?!

I have rebuilt the container many times and cleared the cache. But the message persists.

There is a reference to FLASK_PORT in the .conf file but changing it doesn't change the error message, so I assume it isn't coming from there.

No reference to it in docker-compose.yml or Dockerfile.

Any tips on how to troubleshoot something like this? ๐Ÿ™